jueves, 27 de noviembre de 2014

What a Month!

This November has been my busiest month ever!  I am glad because my computers have been up to the job thanks to Linux.  I still hear people complaining about viruses and about the misbehavior of their OS.  What can I say?  :P  I don't miss those times!

Although I've been away from forums and such, I've managed to help translating MX Linux into my language.  I've helped a bit with antiX, too.

But there's more work to do.  Mechatotoro and I are planning our two lectures for our university's international congress next month.  Of course, we will use Linux.  PCLOS or Mageia this time?  Mechatotoro's computer will have the last word!

miércoles, 5 de noviembre de 2014

Updating to Pisi 1.1!

I was surprised to learn that Pisi Linux released a 1.1 version.  My Pisi 1.0 has been working pretty well, but I wanted to see if I could go to the new version through the updates.  As instructed by Groni, I opened a terminal and typed

sudo pisi up -dy

Soon enough, I was presented all the packages that were about to be downloaded and installed.  The process seemed to go well, but at the end I got an error.

I rebooted my computer and realized that both GRUB and the kernel had been updated.  However, the rest of the updates didn't seem to be installed.

I opened PiSi (the package manager) and saw around 70 packages to be updated.  I proceeded with the update (which was surprisingly fast thanks to PiSi's delta features), hoping to be lucky at the end.

Unfortunately, when applying the changes, I got a weird error:

"it is a folder /usr/share/appdata"

I noticed that the issue happened as soon as the package Fotoxx was to be installed.  Thus, I deselected that one and tried to update once again.

Success: the Packages Installed Successfully as Intended!  :P

Just to double check, I selected Fotoxx and tried to update it.  Yes, I got the error again.

Now I have a Pisi 1.1 system, albeit my old version of Fotoxx.

martes, 4 de noviembre de 2014

KDE Desktop Effects Woes? Try any of these Approaches!

Recently, a fellow Mepis 12 user had problems with a computer.  Some of the desktop effects stopped working after an unknown update.  Thus, I had to try all I knew to fix the problem:

1.  su -c 'update-alternatives --config libGL.so.1'

and chose #1 in the nvidia/diversions.

I also ran

su -c 'update-alternatives --config libglx.so'

and chose #1.  But that had no effect.

2.  su -c 'cd /usr/lib/xorg/modules/extensions;ln -sf $(ls -1 libglx.so.*) libglx.so'

and then restarted the x session.

...It didn't work.

3.  I tried to see if there was anything blacklisted in the file

...But  there was nothing blacklisted there.

4.  Dedoimedo had this easy tutorial:

Basically, it tells you to move the file kwinrc located here:  .kde/share/config/kwinrc

If you do, next time you start X, a new file will be created.

I tried it...but it didn't work, either.

5.  Then, I read that for some Arch Linux users, that solution was pretty extreme.  According to one of them, all you have to do is opening kwinrc to look for this line:


And set it to:  OpenGLIsUnsafe=false

But it turned out that the line was already set to false in the file.

6.  Finally, I tried something of my own.  I noticed that kwinrc on the damaged system was missing the line:


Thus, I asked the owner to add it, just to see what happened.

Who'd have thought! It worked!  :P  Now the system's effects are working again!

This is what I love of Linux.  You can solve problems if you are willing to learn and try.  You are not denied access to your system.