domingo, 30 de enero de 2011

How to Get a Canon Pixma ip1800 Working on Mepis 8.0

Canon used to be my favorite printer manufacturer...until I migrated to Linux and realized the unfriendly policies Canon America has for Linux. I had abandoned all hope of printing on Mepis using my Canon Pixma ip1800.

However, I stumbled upon Tuxgamez!, a blog by obedlink, an Ubuntu user who happened to be in the same situation but found a solution. He published the solution and the drivers here.

True, the blog and the directions are in Spanish, but you just have to click on "descargar archivo" (download file) at the end of the page. The .tar file has directions in English.

You just follow the directions and select the Canon printer driver ip1900 to get your Canon ip1800 working on Mepis.

2 comentarios:

  1. Congratulations! So you got your printer working...Great!
    If you happen to find a way to get Canon ip1000 working, tell me!

  2. Did you check out Canon's site in Australia? They have RPMs, it seems: